Setup Mikrotik sebagai Gateway Server

MikroTik RouterOS™, merupakan system operasi Linux base yang diperuntukkan sebagai
network router. Didesain untuk memberikan kemudahan bagi penggunanya. Administrasinya bisa dilakukan melalui Windows application (WinBox). Selain itu instalasi dapat dilakukan pada Standard computer PC. PC yang akan dijadikan router mikrotikpun tidak memerlukan resource yang cukup besar untuk penggunaan standard, misalnya hanya sebagai gateway. Untuk
keperluan beban yang besar ( network yang kompleks, routing yang rumit dll) disarankan untuk mempertimbangkan pemilihan resource PC yang memadai.

Fasilitas pada mikrotik antara lain sebagai berikut :
– Protokoll routing RIP, OSPF, BGP.
– Statefull firewall
– HotSpot for Plug-and-Play access
– remote winbox GUI admin

Lebih lengkap bisa dilihat di http://www.mikrotik.com.
Meskipun demikian Mikrotik bukanlah free software, artinya kita harus membeli licensi terhadap
segala fasiltas yang disediakan. Free trial hanya untuk 24 jam saja. Kita bisa membeli software
mikrotik dalam bentuk CD yang diinstall pada Hard disk atau disk on module (DOM). Jika kita
membeli DOM tidak perlu install tetapi tinggal menancapkan DOM pada slot IDE PC kita.
Langkah-langkah berikut adalah dasar-dasar setup mikrotik yang dikonfigurasikan untuk jaringan
sederhana sebagai gateway server.

Berikut ini adalah langkah-langkahnya

01. Langkah pertama adalah install Mikrotik RouterOS pada PC atau pasang DOM.

02. Login Pada Mikrotik Routers melalui console :

MikroTik v2.9.7
Login: admin
Password:

Sampai langkah ini kita sudah bisa masuk pada mesin Mikrotik. User default adalah admin
dan tanpa password, tinggal ketik admin kemudian tekan tombol enter.

03. Untuk keamanan ganti password default

[admin@Mikrotik] > password
old password: *****
new password: *****
retype new password: *****
[admin@ Mikrotik]] >

04. Mengganti nama Mikrotik Router, pada langkah ini nama server akan diganti menjadi “Waton”

[admin@Mikrotik] > system identity set name=Waton
[admin@Waton] >

05. Melihat interface pada Mikrotik Router

[admin@Mikrotik] > interface print
Flags: X - disabled, D - dynamic, R - running
 #    NAME     TYPE      RX-RATE    TX-RATE    MTU
 0  R ether1   ether       0          0       1500
 1  R ether2   ether       0          0       1500
[admin@Mikrotik] >

06. Memberikan IP address pada interface Mikrotik. Misalkan ether1 akan kita gunakan untuk
koneksi ke Internet dengan IP 192.168.0.1 dan ether2 akan kita gunakan untuk network local kita dengan IP 172.16.0.1

[admin@Waton]   >   ip   address   add   address=192.168.0.1 
netmask=255.255.255.0 interfac
e=ether1
[admin@Waton]   >   ip   address   add   address=172.16.0.1 
netmask=255.255.255.0 interfac
e=ether2

07. Melihat konfigurasi IP address yang sudah kita berikan

[admin@Waton] >ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS         NETWORK         BROADCAST       INTERFACE
 0   192.168.0.1/24  192.168.0.0     192.168.0.63    ether1   
 1   172.16.0.1/24   172.16.0.0      172.16.0.255    ether2   
[admin@Waton] >

08. Memberikan default Gateway, diasumsikan gateway untuk koneksi internet adalah 192.168.0.254

[admin@Waton] > /ip route add gateway=192.168.0.254

09. Melihat Tabel routing pada Mikrotik Routers

[admin@Waton] > ip route print        
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf 
 # DST-ADDRESS           PREFSRC        G GATEWAY
 DISTANCE INTERFACE
 0 ADC 172.16.0.0/24     172.16.0.1      ether2  
 1 ADC 192.168.0.0/26    192.168.0.1     ether1   
 2 A S 0.0.0.0/0         192.168.0.254   ether1   
[admin@Waton] >

10. Tes Ping ke Gateway untuk memastikan konfigurasi sudah benar

[admin@Waton] > ping 192.168.0.254
192.168.0.254 64 byte ping: ttl=64 time

11. Setup DNS pada Mikrotik Routers

[admin@Waton] > ip dns set primary-dns=192.168.0.10 allow-remote-requests=no
[admin@Waton] > ip dns set secondary-dns=192.168.0.11 allow-remote-requests=no

12. Melihat konfigurasi DNS

[admin@Waton] > ip dns print             
                primary-dns: 192.168.0.10
                secondary-dns: 192.168.0.11
                allow-remote-requests: no
                cache-size: 2048KiB
                cache-max-ttl: 1w
                cache-used: 16KiB
[admin@Waton] >

13. Tes untuk akses domain, misalnya dengan ping nama domain

[admin@Waton] > ping yahoo.com 
216.109.112.135 64 byte ping: ttl=48 time=250 ms
10 packets transmitted, 10 packets received, 0% packet loss
round-trip min/avg/max = 571/571.0/571 ms
[admin@Waton] >

Jika sudah berhasil reply berarti seting DNS sudah benar.

14. Setup Masquerading, Jika Mikrotik akan kita pergunakan sebagai gateway server maka agar client computer pada network dapat terkoneksi ke internet perlu kita masquerading.

[admin@Waton]   >   ip   firewall   nat   add   action=masquerade   out-interface=ether1
chain: srcnat 
[admin@Waton] >

15. Melihat konfigurasi Masquerading

[admin@Waton] ip firewall nat print 
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=ether1 action=masquerade 
[admin@Waton] >

Setelah langkah ini bisa dilakukan pemeriksaan untuk koneksi dari jaringan local. Dan jika berhasil berarti kita sudah berhasil melakukan instalasi Mikrotik Router sebagai Gateway server. Setelah terkoneksi dengan jaringan Mikrotik dapat dimanage menggunakan WinBox yang bisa di download dari Mikrotik.com atau dari server mikrotik kita. Misal Ip address server mikrotik kita 192.168.0.1, via browser buka http://192.168.0.1 dan download WinBox dari situ.

Jika kita menginginkan client mendapatkan IP address secara otomatis maka perlu kita setup
dhcp server pada Mikrotik. Berikut langkah-langkahnya :

01.Buat IP address pool

/ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20

02. Tambahkan DHCP Network dan gatewaynya yang akan didistribusikan ke client

Pada contoh ini networknya adalah 172.16.0.0/24 dan gatewaynya 172.16.0.1

/ip dhcp-server network add address=172.16.0.0/24 gateway=172.16.0.1

03. Tambahkan DHCP Server ( pada contoh ini dhcp diterapkan pada interface ether2 )

/ip dhcp-server add interface=ether2 address-pool=dhcp-pool

04. Lihat status DHCP server

[admin@Waton] > ip dhcp-server print 
Flags: X - disabled, I - invalid 
 #   NAME  INTERFACE RELAY  ADDRESS-POOL LEASE-TIME ADD-ARP
 0 X dhcp1    ether2    

Tanda X menyatakan bahwa DHCP server belum enable maka perlu dienablekan terlebih
dahulu pada langkah 5.

05. Jangan Lupa dibuat enable dulu dhcp servernya

/ip dhcp-server enable 0

kemudian cek kembali dhcp-server seperti langkah 4, jika tanda X sudah tidak ada berarti
sudah aktif.

06. Tes Dari client

sumber : http://mikrotik.com

Semoga bermanfaat. Terima kasih

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s